【股票指标公式下载】-【通达信】超准完美买卖(主力、散户、动能趋势线)

【股票指标公式下载】-【通达信】超准完美买卖(主力、散户、动能趋势线)

【通达信】超准完美买卖(主力、散户、动能趋势线)-指标公式源码

DRAWTEXT(CROSS(MA(C,10),MA(C,20)),H,'-------------'),LINETHICK2; DRAWBAND(MA(C,3),RGB(230,0,250),HHV(MA(C,5),10),RGB(0,100,150));

MA5:MA(CLOSE,5);

MA10:MA(CLOSE,10);

MA20:MA(CLOSE,20);

MA30:MA(CLOSE,30);

MA60:MA(CLOSE,60),CIRCLEDOT;

MA120:MA(CLOSE,120),CIRCLEDOT;

RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

X:=LLV(J,2)=LLV(J,8);

Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0);

主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);

散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);

VAR2:=LLV(LOW,10);

VAR3:=HHV(HIGH,25);

动能趋势线:=100*EMA((CLOSE-VAR2)/(VAR3-VAR2),4);

DRAWTEXT(CROSS(动能趋势线,70),HIGH*1.02,'险'),COLORGREEN; DRAWTEXT(CROSS(动能趋势线,80),HIGH*1.02,'减'),COLOR00FF00; DRAWTEXT(CROSS(动能趋势线,87.5),HIGH*1.02,'出局'),COLORWHITE; DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW,'短进'),COLORFF00FF; DRAWTEXT(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,'见底'),COLORRED; DRAWICON(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,1);

涨家数:INDEXADV,NODRAW,COLORRED;

跌家数:INDEXDEC,NODRAW,COLORGREEN;

{涨跌停显示}

涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0); STICKLINE(涨停,O,C,3,0),COLORYELLOW;

ZDF:=(C-REF(C,1))/REF(C,1)*100;

STICKLINE(ZDF<-9.9,O,C,3,0),COLORGREEN;

相关推荐
相关主题
热门推荐