multisim简介

Multisim 11 软件基本介绍

NI Multisim软件是一个专门用于电子电路仿真与设计的EDA工具软件。作为 Windows 下运行的个人桌面电子设计工具,NI Multisim 是一个完整的集成化设计环境。NI Multisim 计算机仿真与虚拟仪器技术可以很好地解决理论教学与实际动手实验相脱节的这一问题。学生可以很方便地把刚刚学到的理论知识用计算机仿真真实的再现出来,并且可以用虚拟仪器技术创造出真正属于自己的仪表。NI Multisim软件绝对是电子学教学的首选软件工具。

直观的图形界面

整个操作界面就像一个电子实验工作台,绘制电路所需的元器件和仿真所需的测试仪器均可直接拖放到屏幕上,轻点鼠标可用导线将它们连接起来,软件仪器的控制面板和操作方式都与实物相似,测量数据、波形和特性曲线如同在真实仪器上看到的;

丰富的元器件

提供了世界主流元件提供商的超过17000多种元件,同时能方便的对元件各种参数进行编辑修改,能利用模型生成器以及代码模式创建模型等功能,创建自己的元器件。

强大的仿真能力

以SPICE3F5和Xspice的内核作为仿真的引擎,通过Electronic workbench 带有的增强设计功能将数字和混合模式的仿真性能进行优化。包括SPICE仿真、RF仿真、MCU仿真、VHDL仿真、电路向导等功能。

丰富的测试仪器

提供了22种虚拟仪器进行电路动作的测量:

Multimeter(万用表)

Function Generatoer(函数信号发生器)

Wattmeter(瓦特表)

Oscilloscope(示波器)

Bode Plotter(波特仪)

Word Generator(字符发生器

Logic Analyzer(逻辑分析仪)

Logic Converter(逻辑转换仪)

Distortion Analyer(失真度仪)

Spectrum Analyzer(频谱仪)

Network Analyzer(网络分析仪)

Measurement Pribe(测量探针)

Four Channel Oscilloscope(四踪示波器)

Frequency Counter(频率计数器)

IV Analyzer(伏安特性分析仪)

Agilent Simulated Instruments(安捷伦仿真仪器)

Agilent Oscilloscope(安捷伦示波器)

Tektronix Simulated Oscilloscope(泰克仿真示波器)

Voltmeter(伏特表)

Ammeter(安培表)

Current Probe(电流探针)

Lab VIEW Instrument(Lab VIEW仪器)

这些仪器的设置和使用与真实的一样,动态互交显示。除了Multisim提供的默认的仪器外,还可以创建LabVIEW的自定义仪器,使得图形环境中可以灵活地可升级地测试、测量及控制应用程序的仪器。

完备的分析手段

Multisimt提供了许多分析功能:

DC Operating Point Analysis(直流工作点分析)

AC Analysis(交流分析)

Transient Analysis(瞬态分析)

Fourier Analysis(傅里叶分析)

Noise Analysis(噪声分析)

Distortion Analysis(失真度分析)

DC Sweep Analysis(直流扫描分析)

DC and AC Sensitvity Analysis(直流和交流灵敏度分析)

Parameter Sweep Analysis(参数扫描分析)

Temperature Sweep Analysis(温度扫描分析)

Transfer Function Analysis(传输函数分析)

Worst Case Analysis(最差情况分析)

Pole Zero Analysis(零级分析)

Monte Carlo Analysis(蒙特卡罗分析)

Trace Width Analysis(线宽分析)

Nested Sweep Analysis(嵌套扫描分析)

Batched Analysis(批处理分析)

User Defined Analysis(用户自定义分析)

它们利用仿真产生的数据执行分析,分析范围很广,从基本的到极端的到不常见的都有,并可以将一个分析作为另一个分析的一部分的自动执行。集成LabVIEW和Signalexpress

快速进行原型开发和测试设计,具有符合行业标准的交互式测量和分析功能;

独特的射频(RF)模块

提供基本射频电路的设计、分析和仿真。射频模块由RF-specific(射频特殊元件,包括自定义的RF SPICE模型)、用于创建用户自定义的RF模型的模型生成器、两个RF-specific 仪器(Spectrum Analyzer频谱分析仪和Network Analyzer网络分析仪)、一些RF-specific 分析(电路特性、匹配网络单元、噪声系数)等组成;

强大的MCU模块

支持4种类型的单片机芯片,支持对外部RAM、外部ROM、键盘和LCD等外围设备的仿真,分别对4 种类型芯片提供汇编和编译支持;所建项目支持C代码、汇编代码以及16进制代码,并兼容第三方工具源代码;包含设置断点、单步运行、查看和编辑内部RAM、特殊功能寄存器等高级调试功能。

完善的后处理

对分析结果进行的数学运算操作类型包括算术运算、三角运算、指数运行、对数运算、复合运算、向量运算和逻辑运算等;

详细的报告

能够呈现材料清单、元件详细报告、网络报表、原理图统计报告、多余门电路报告、模型数据报告、交叉报表7种报告;

兼容性好的信息转换

提供了转换原理图和仿真数据到其他程序的方法,可以输出原理图到PCB布线(如Ultiboard、OrCAD、PADS Layout2005、P-CAD和Protel);输出仿真结果到MathCAD、Excel 或LabVIEW;输出网络表文件;向前和返回注;提供 Internet Design Sharing(互联网共享文件)

电路的构建及仿真:

单元电路、功能电路、单片机硬件电路的构建及相应软件调试的仿真。系统的组成及仿真:Commsim 是一个理想的通信系统的教学软件。它很适用于如‘信号与系统’、‘通信’、‘网络’等课程,难度适合从一般介绍到高级。使学生学的更快并且掌握的更多。Commsim 含有200多个通用通信和数学模块,包含工业中的大部分编码器,调制器,滤波器,信号源,信道等,Commsim 中的模块和通常通信技术中的很一致,这可以确保你的学生学会当今所有最重要的通信技术。要观察仿真的结果,你可以有多种选择:时域,频域,XY图,对数坐标,比特误码率,眼图和功率谱。仪表仪器的原理及制造仿真:可以任意制造出属于自己的虚拟仪器、仪表,并在计算机仿真环境和实际环境中进行使用。

(1)可以根据自己的需求制造出真正属于自己的仪器;

(2)所有的虚拟信号都可以通过计算机输出到实际的硬件电路上;

(3)所有硬件电路产生的结果都可以输回到计算机中进行处理和分析。

●通过直观的电路图捕捉环境, 轻松设计电路

●通过交互式SPICE仿真, 迅速了解电路行为

●借助高级电路分析, 理解基本设计特征

●通过一个工具链, 无缝地集成电路设计和虚拟测试

●通过改进、整合设计流程, 减少建模错误并缩短上市时间

(二)Multisim 11使用简介

Multisim 11软件以图形界面为主,采用菜单、工具栏和热键相结合的方式,具有一般Windows应用软件的界面风格,用户可以根据自己的习惯和熟悉程度自如使用。

一、Multisim的主窗口界面。

multisim简介

界面由多个区域构成:菜单栏,各种工具栏,电路输入窗口,状态条,列表框等。通过对各部分的操作可以实现电路图的输入、编辑,并根据需要对电路进行相应的观测和分析。用户可以通过菜单或工具栏改变主窗口的视图内容。

二、菜单栏简介

multisim简介

菜单中有一些与大多数Windows 平台上的应用软件一致的功能选项,如File ,Edit ,View ,Options ,Help 。此外,还有一些EDA 软件专用的选项,如Place ,Simulation ,Transfer 以及Tool 等。 1. File 菜单

File 菜单中包含了对文件和项目的基本操作以及打印等命令。

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

2. Edit 菜单

Edit 命令提供了类似于图形编辑软件的基本编辑功能,用于对电路图进行编辑。

multisim简介

multisim简介

multisim简介

multisim简介

Orientation 菜单的子菜单:

multisim简介

multisim简介

3.View 菜单

multisim简介

multisim简介

通过View 菜单可以决定使用软件时的视图,对一些工具栏和窗口进行控制。

multisim简介

4.Place 菜单

通过Place 命令输入电路图。

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

5.Simulate 菜单

通过Simulate 菜单执行仿真分析命令。

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

6.Transfer 菜单

Transfer 菜单提供的命令可以完成Multisim 对其它EDA 软件需要的文件格式的输出。

multisim简介

multisim简介

multisim简介

multisim简介

7.Tools 菜单

Tools 菜单主要针对元器件的编辑与管理的命令。

multisim简介

8.Reports 菜单

multisim简介

9.Options 菜单

通过Option 菜单可以对软件的运行环境进行定制和设置。

10.Help 菜单

Help 菜单提供了对Multisim 的在线帮助和辅助说明。

元件向导 数据库 变量管理 设置活动变量 重命名/编号元件 电气规则检查

清除ERC 日志 切换未连接标记 屏幕捕捉范围 网络设计资源

材料清单 元件详细报告 网络表报告 对照报告 原理图统计

多余门报告 全局设置

图表属性

锁定工具 自定义用户界面

multisim简介

multisim简介

multisim简介

multisim简介

multisim简介

三、对电路进行仿真运行,通过对运行结果的分析,判断设计是否正确合理,是EDA 软件的一项主要功能。为此,Multisim 为用户提供了类型丰富的虚拟仪器,可以从Design 工具栏 Instruments 工具栏,如图,或用菜单命令(Simulation/ instrument )选用这11种仪表,如图所示。在选用后,各种虚拟仪表都以面板的方式显示在电路中。

multisim简介

图 Instruments 工具栏

multisim简介

图 调用虚拟仪器菜单示意图

下面将11种虚拟仪器的名称及表示方法总结如下,表所示:

multisim简介

multisim简介

(三)Multisim 11仿真基本流程举例简介

Multisim 11提供了多种仿真分析功能,给电路分析和仿真实验研究带来了极大的方便。其分析方法包括:直流工作点分析、交流分析、瞬态分析、直流扫描分析、傅立叶分析、噪声分析、失真分析、灵敏度分析、参数扫描分析、温度扫描分析、极点-零点分析、传递函数分析、最坏情况分析、蒙特卡罗分析、批处理分析和用户自定义分析,共16种分析方法,下面就其结合一个简单电路的电压测量、波形测试、并做交流分和瞬间分析来对Multisim 11的创建电路、仪器仪表使用、电路仿真与分析的整个流程做以下说明。

1、创建电路

(1)、打开Multisim 11,出现打开窗口,进入启动过程。

multisim简介

(2)、Multisim 11 打开后,出现Multisim 11主界面。默认情况下,已自动新建一个原理图文件,并默认名为Design1,我们可以保存电路时,对其重命名。

multisim简介

(3)、修改电路图元件的使用标准。点击option-->Global Preferences,

multisim简介

出现下图所示对话框

multisim简介

点击Parts选项卡,在Symbol standard处,有ANSI(美国标准)和DIN(德国标准)的元件可供选择,如图:

multisim简介

常见元件的ANSI和DIN外形如下图(左为ANSI,右为DIN)所示:

multisim简介

(4)、点击Place,然后点击component,如图

multisim简介

(5)、出现添加元件对话框

multisim简介

(6)、选择需要的元件后,点击ok,则元件即可添加到原理图中。

(7)、双击元件,出现该元件的属性对话框,可以根据实际需要对元器件的参数进行修改,如电阻、电容值、电源电源、频率等参数进行修改,并点击ok确定。

multisim简介

(8)、依次类推,将所需的全部元器件添加进原理图,并根据实际设计连接电路,如图

multisim简介

2、仪器仪表的使用

假设我们需要测量上图电路中0与1点之间的电压,并查看上述两点之间的波形,我们可以调用比较简单的两个仪表,万用表和示波器.。

(1)、Multisim为用户提供了类型丰富的虚拟仪器,可以从Design工具栏 Instruments 工具栏,如下图,或用菜单命令(Simulation/ instrument)选用需要的仪表,或(点击右侧

仪表工具栏中的和),就可以将万用表和示波器添加进电路,我们只需适当连接即可。

multisim简介

(2)、双击上述两种仪表,可以将其虚拟界面打开,如图

multisim简介

(3)、点击上图中的绿色图标,开始仿真,即可出现如图所示的仿真结果。

multisim简介

3、仿真分析举例

Multisim 11提供了多种仿真分析功能,给电路分析和仿真实验研究带来了极大的

方便。下面就结合上述电路对交流分和瞬间分析做以示范,请读者朋友结合后续各章节的相关讲述,举一反三,学习其他仿真分析方法。

(1)、交流分析

单击Simulate/Analyses/AC Analysis命令,

multisim简介

弹出一个“AC Analysis”对话框,如图所示。该对话框有4个选项卡。

multisim简介

其中,Frequency Parameters选项卡主要用于AC分析时频率参数的设置,设置内容包括:

Start frequency:设置交流分析的起始频率。

Stop frequency:设置交流分析的终止频率。

Sweep type:设置交流分析的扫描方式,主要有Decade(十倍程扫描)、Octave(八倍程扫描)和Linear(线性扫描)。通常采用十倍程扫描选项,一对数方式展现。

Number of points per decade:设置每十倍频率的取样数量。设置的值越大,则分析所需的时间越长。

Vertical scale:设置纵坐标的刻度。主要有Decibel(分贝)、Octabe(八倍程)、Linear (线性)和Logarthmic(对数),通常采用Logarthmic或Linear选项。

设其频率为1Hz,中止频率为10GHz,扫描方式为Decade,取样值设为10(此处举例,具体参数请结合需要自行合理设置)。

另外,在Output variables选择卡中,选定结点1作为仿真分析变量,还可以选定更多的需要分析的结点,只需点击选中,然后点击对话框中间的Add即可,如下图所示

multisim简介

在Analysis Options选项卡中,Title foe analysis栏输入交流分析AC Analysis(系统已自动设置好),最后单击Simulate按钮进行分析,其结果如图所示。

multisim简介

(2)、瞬态分析

瞬态分析是一种非线性时域分析,可以在激励信号(或没有任何激励信号)的作用下计算电路的时域响应。分析时,电路初试状态可由用户自行设置,也可以由程序自动进行直流分析,用直流分析的结果作为电路的初始状态。

瞬态分析的结果通常是分析结点的电压波形,故用示波器可观测到相同的结果。下面以RLC正弦交流电路为例,说明瞬态分析的具体操作步骤。

单击Simulate/Analyses/Transient Analysis…命令,如图:

multisim简介

弹出一个“Transient Analysis”对话框,如图2所示。

该对话框有4个选项卡。

其中,Analysis Parameters选项卡主要用于瞬态分析中时间参数的设置,分为两个区域。

(1)Initial Conditions区设置仿真开始时的初始条件,共4个选项:

Automatically determine initial conditions(由程序自动设置初始值);

Set to zero(将初始值设为0);

User defined(由用户定义初始值);

Calculate DC operating point(通过计算直流工作点得到初始值)。

(2)Parameters区用于时间参数的设置,包括:

Start time(开始分析的时间);

End time(结束分析的时间);

Maximum time step settings(最大时间步长)。

若选中Maximum time step settings选项,其下又有3个单选项:

Minimum number of time points:用于设置从开始时间到结束时间内最少取样的点数。若设置的数值越大,在一定的时间内分析的点数越大,则分析时间也会越长。

Maximum time step(TMAX):用于设置仿真分析时的时间步长。

Generate time steps automatically:用于自动设置仿真分析时间时的时间步长。

我们选取Automatically determine initial conditions选项,即由程序自动设置初始值,然后将开始分析时间设为0,结束时间设为0.1s,选取Maximum time step(TMAX)选项以及Generate time steps automatically选项。

multisim简介

在Output variables选项卡中,选择结点1作为仿真分析变量,还可以选定更多的需要分析的结点,只需点击选中,然后点击对话框中间的Add即可,如下图所示

multisim简介

Analysis(系统已自动设置好),最后单击Simulate按钮进行分析,其结果如图3所示。

multisim简介

结果相同。

相关推荐
相关主题
热门推荐