ch26_ok

第26章Internet上的文件操作

学习要点

从Internet上打开图形文件

从Internet上插入文件

在Internet上存储文件

26

436 在AutoCAD 2000,2000i和2002版本中,用户在使用诸如选择(Select)、另存(Save

As)、插入(Insert)和输出(Export)等各种对话框时,均可直接对存储在Internet上的文件进行操作,使AutoCAD系统和Internet紧密地结合在一起。

26.1 从Internet打开图形文件

用户调用Open命令来打开图形文件时,系统弹出“Select File(选择文件)”对话框,如图26-1所示。

图26-1 “Select File”对话框

该对话框不仅可以帮助用户查询和选择本地计算机和局域网中的文件,同时也提供了访问Internet的功能,使用户可以直接进入Internet查询并打开所需文件。现介绍对话框中与网络相关的几个部分及相应的功能:

1. 位置列表(Places List)

在对话框左侧的位置列表中提供了8个预定义的文件位置,为用户访问文件提供了一个快速通道。其具体功能如下:

(1)History(历史):单击该图标可显示最近访问过的文件的快捷方式,以此选择并

打开图形文件。这些快捷方式保存在特定的文件夹中,例如在Window 98系统中,

保存在操作系统引导目录中的“\Application Data\Autodesk\AutoCAD\Recent\Select

File\”文件夹中。

(2)My Documents(我的文档):单击该图标可打开“My Documents”文件夹,并列

ch26_ok

ch26_ok

ch26_ok

437

出该文件夹中的子文件夹,以及可访问的文件。该文件夹的位置与操作系统有关。 (3) Favorites (收藏夹):单击该图标可打开“

Favorites ”文件夹,并列出该文件夹中

的子文件夹,以及可访问的文件。该文件夹的位置与操作系统有关。

(4) Desktop (桌面):单击该图标可打开并显示桌面上的子文件夹,以及可访问的文

件。

(5) Buzzsaw :单击该图标可访问http://m.wendangku.net/doc/8130223567ec102de2bd8969.html 网站(一个关于建筑设计和构造的B2B

网站)的。如果用户有project hosting 帐户,则显示用户的所有工程;如果用户没

有project hosting 帐户,则系统将打开Web 浏览器,并连接到该网站,以便用户

设置project hosting 帐号。

(6) RedSpark :单击该图标可访问http://m.wendangku.net/doc/8130223567ec102de2bd8969.html 网站(一个关于制造业的B2B 网站)。

如果用户有project hosting 帐户,则显示用户的所有工程;如果用户没有project

hosting 帐户,则系统将打开Web 浏览器,并连接到该网站,以便用户设置project

hosting 帐号。

(7) FTP :单击该图标显示FTP 地址列表,并可建立连接。用户可通过对话框中的“Tools

(工具)”菜单来添加、删除或设置FTP 地址。

(8) Point A :访问Autodesk 的门户网站Autodesk Point A 。

用户可直接拖放位置列表中的图标进行重新排序,或把文件列表中的文件夹图标拖放进去。也可以在位置列表中单击右键弹出快捷菜单,用于添加、删除或修改各个图标。

注意 Point A 、Buzzsaw 和RedSpark 图标不能被删除。其他标准图标被删除后可通过右键菜单中的“Restore Standard Folders ”项进行恢复。

图26-2 AutoCAD 系统的内部浏览器窗口

单击“Select File (选择文件)”对话框中的

按钮,系统弹出“Browse the Web ”对话

框,如图26-2所示。

ch26_ok

ch26_ok

26

438 该对话框是Microsoft 网络浏览器的一个简化版本,用户可以通过这个对话框在网站上

浏览文件,当用户找到所需要的文件后,单击按钮即可。

3. Tools (工具)菜单

该菜单中各选项的功能如下:

(1) Find (查找):选择该项将弹出“Find (查找)”对话框,如图26-3所示。该对

话框的功能与Windows 系统中的“查找”对话框类似。

图26-3 “Find ”对话框

(2) Locate (定位):选择该项将在AutoCAD 系统的搜索路径中查找并定位在“File

(文件)”框中指定的文件,如果没有找到,则给出提示。

(3) Add/Modify FTP Locations (添加/修改FTP 地址):选择该项将弹出“Add/Modify

FTP Locations (添加/修改FTP 地址)”对话框,如图26-4所示。用户可在该对

话框中将某个FTP 地址添加到列表中,并可设置登录帐号及密码。

图26-4 “Add/Modify FTP Locations ”对话框

(4) Point A 登录提示:当从位置列表中选择了Point A 时,将提示用户输入正确的ID

和密码。

(5) Add Current folder to Places (添加当前文件夹到位置列表):将当前的文件夹图标

ch26_ok

ch26_ok

439

添加到位置列表中。

(6) Add to Favorites (添加到收藏夹):创建当前文件夹或选择的文件、文件夹的快

捷方式,并添加到“Favorites ”文件夹中。

注意 Find 和Locate 选项只能定位本地系统上的文件,而不能定位Internet 上文件。 说明 “

Browser the Web ”对话框的缺省Internet 位置是“http://m.wendangku.net/doc/8130223567ec102de2bd8969.html ”。用户可通过如下操作来改变其缺省位置:

(1) 打开“Option (选项)”对话框。

(2) 选择“Files (文件)”选项卡。

(3) 选择“Menu ,Help ,and Miscellaneous File Names (菜单、帮助和其他文件名称)”

选项。

(4) 选择“Default Internet Location (缺省Internet 网址)”选项。

(5) 选择“http://m.wendangku.net/doc/8130223567ec102de2bd8969.html ”项后,单击“浏览”按钮来指定新的网址。

专家指点 Open 命令不能把文件从Internet 上直接拷贝到AutoCAD 中。Open 命令从Internet 上将文件拷贝到计算机指定的临时子目录上,如C:\Windows\Temp ,然后从硬盘上将图形装入AutoCAD 中。这种方法称做高速缓存(caching)。高速缓存加快图形的处理过程,因为图形文件放到了计算机的快速硬盘上,而不是速度相对缓慢的Internet 上。

26.2 从Internet 上插入块文件及其他文件

在AutoCAD 中,用户不仅可以打开Internet 上的文件,还可以将Internet 文件插入到当前的图形文件中。例如当用户在当前文件中调用“Insert ”命令插入块时,选择“Insert (插入)”对话框中的按钮后,弹出“Select Drawing File (选择图形文件)”对话框,如图26-5所示。

图26-5 “Select Drawing File ”对话框

从图中可以看到,该对话框的结构和功能与26.1节中“Select File ”对话框完全一样,这里不再重复讲述。

与插入块文件的方法类似,用户还可在插入外部参照、ACIS 文件、DXB 文件、WMF

ch26_ok

ch26_ok

ch26_ok

ch26_ok

ch26_ok

26

440 文件、Markup 文件以及超级链接时使用Internet 上的相关文件。

有些对话框中的功能较简单,例如图26-6所示的插入3D Studio 文件的对话框。

该对话框右上角的三个按钮用于Internet 相关的操作,具体含义为:

(1) 按钮:打开“Browse to Web ”对话框。

(2) 按钮:打开“Favorites ”文件夹。

(3) 按钮:创建当前文件夹或选择的文件、文件夹的快捷方式,并添加到“Favorites ”

文件夹中。

与该对话框类似的还有插入光栅图像对话框等。

图26-6 “3D Studio File Import ”对话框

26.3 在Internet 上存储图形文件

当用户在AutoCAD 中编辑完一个图形之后,可以将其保存在本地磁盘上,也可保存在

Internet 上。当然,有时使用网络资源时,需要用户具有一定的访问权限。

图26-7 “Save Drawing As ”对话框

在AutoCAD 中打开“Save Drawing As ”对话框,如图26-7所示,该对话框的结构和

ch26_ok

441 用法与“Select File ”等对话框基本一致。

26.4 在Internet 上访问其他文件

除了图形文件以外,AutoCAD 还允许用户在如下所示的各种对话框中访问Internet 上其他类型的文件,其中包括:

(1) 线型(Linetype )文件:在“Linetype Manager (线型管理器)”对话框中单击

按钮弹出的“Select Linetype File ”对话框。

(2) 多线(Multiline )文件: 从“Load Multiline Styles (载入多线样式)”对话框中单

ch26_ok

击按钮弹出的“Load Multiline Style From File ”对话框。

(3) 图层(Layer )文件:在“Layer States Manager (图层状态管理器)”对话框中单

击按钮弹出的“Import layer state ”对话框。

(4) 应用程序(Application ):选择菜单【Tools (工具)】→【Load Application …(载

入应用程序)】弹出的“Load/Unload Applications ”对话框。

(5) 脚本(Script )文件:选择菜单【Tools (工具)】→【Run Script …(运行脚本文

件)】弹出的“Select Script File ”对话框。

(6) 菜单(Menu )文件:在“Menu Customization (菜单定制)”对话框中单击

按钮弹出的“Select Menu File ”对话框。

(7) 图像(Image )文件:选择菜单【Tools (工具)】→【Display Image (显示图像)】

→【View …(视图)】弹出的“Replay ”对话框。

26.5 小 结

本章主要介绍了AutoCAD 对Internet 上的文件的各种使操作方法。

相关推荐
相关主题
热门推荐