maxwell和workbench的联合仿真

Coupling Maxwell Designs with ANSYS Thermal via

Workbench

Coupling Maxwell2D/3D V15 with ANSYS R14 is supported via the Workbench schematic. Thermal feedback is supported for Maxwell magnetostatic, eddy current, and transient types. Users also need to setup the design and geometry appropriately. An appropriate design should be temperature-dependent, and have one or more solve setups that are enabled for thermal feedback.

1. The easiest way to add a Maxwell 2D or 3D design to a Workbench schematic is

to import a working design via Workbench File>Import. The imported design is placed in the Workbench schematic after it is successfully imported.

2. Next, insert a Steady-State Thermal system and change its Analysis Type to 2D or 3D, (depending on the Maxwell design type) by right clicking on the Geometry cell and selecting Properties. It is important to change the Steady-State Thermal system's analysis type before setting up its geometry.

maxwell和workbench的联合仿真

3. To setup the Steady-State Thermal system's geometry, you must first export the Maxwell geometry using sat or step format as follows:

a. Select the Modeler>Export menu item.

b. Select the desired model geometry format (sat or step), and the save location in the dialog box and save the file for use by ANSYS Workbench.

4. Import the file via the Geometry module of the Steady-State Thermal system.

a. To access the Geometry module, double click on the Geometry cell in the Steady-State Thermal system to launch DesignModeler.

b. Select File>Import External Geometry File and browse for the geometry file exported from Maxwell.

c. After the geometry file is imported, right-click on the root folder of the modeler project tree and select Generate. (When the geometry file is of a Maxwell 2D RZ design, users can rotate the geometry in DesignModeler by creating a body operation.)

maxwell和workbench的联合仿真

5. Close DesignModeler and refresh the Model cell of the Steady-State Thermal system by right-clicking the Model cell and selecting Refresh.

6. The geometry mode of the Steady-State Thermal system can be changed via the ANSYS Mechanical user interface.

a. Launch Mechanical by double clicking the Setup cell of the Steady-State Thermal system.

b. Select Geometry in the project tree and the Definition of Geometry will be shown in the Detail window.

c. Select either Plane Stress or Axisymmetric as the value for the property 2D (or 3D) Behavior.

7. To setup the coupling, drag the Solution cell of the Maxwell system and drop it on the Setup cell of the Steady-State Thermal system.

maxwell和workbench的联合仿真

8. Note that the Maxwell Solution cell is tagged with a “Lighting Bolt” symbol. Right-click on the Maxwell Solution cell and select Update. This will initiate a Maxwell simulation if it is not already solved. Once Maxwell's solution is available, the “Lighting Bolt” changes to a “Green Check”symbol.

9. To “push” the coupling into Steady-State Thermal, right-click on the Steady-State Thermal Setup cell and select Refresh.

10. After refresh is finished, you can launch ANSYS Mechanical by double-clicking the Setup cell to finish the coupling setup.

11. In the ANSYS Mechanical application project tree, an Imported Load

(Maxwell2DSolution), or (Maxwell3DSolution), item should already be inserted. Select the Imported Load folder to view its details. Because the inserted Maxwell2D (or 3D) system supports thermal feedback, the Details window shows information regarding how the temperature result should be exported, and what type of mesh mapping should be used.

maxwell和workbench的联合仿真

12. To finish the coupling setup, you must insert either an imported Heat Generation or an imported Heat Flux boundary condition. Heat Generation is used

when mapping loss from objects in Maxwell; and Heat Flux should be used to map the loss from the edges of objects in Maxwell. Users can insert multiple Heat Generation or Heat Flux loads via the Imported Load (Maxwell2DSolution), or Imported Load(Maxwell3DSolution) objects.

13. To insert a Heat Generation, use Body select by clicking the icon in the

Mechanical Toolbar. Then click on the objects where the EM loss should be imported. After all the desired objects are selected, right-click on Imported Load (Maxwell2DSolution)> Insert > Heat Generation, or Imported

Load(Maxwell3DSolution) > Insert > Heat Generation.

maxwell和workbench的联合仿真

A sub-item named Imported Heat Generation will appear in the project tree.

14. Click on the Imported Heat Generation tree item to view its details.

maxwell和workbench的联合仿真

15. In the Transfer Definition section, users can setup the source Maxwell solution by pulling down the Ansoft Solution combo box and select one of the listed Maxwell solutions.

16. Right-clicking on Imported Heat Generation > Import Load will import loss from the Ansoft Solution selected for this load. After import has completed, the Import Heat Generation item becomes a folder, and an entry called Imported Load Transfer Summary is listed. Select the Imported Load Transfer Summary entry and the scaling factors used to export the load from Maxwell will be displayed in the Comment window.

maxwell和workbench的联合仿真

17. Selecting Import Heat Generation should show an overlay-plot of the imported load. The loss mapping from Maxwell can be verified by comparing this overlay-

plot with an Ohmic-Loss field overlay plot in Maxwell.

maxwell和workbench的联合仿真

18. Create a Convection boundary to complete the thermal setup. Use Edge select by clicking the icon at the Mechanical Toolbar and then Edit > Select All.

With the edges selected, right-click on the Steady-State Thermal project tree item and insert a Convection. With the Convection item selected, change its Film Coefficient to 5 W/m2 via the Detail window. Right-click on the Solution tree item and select Solve. After the thermal solution is finished, users can insert a Temperature plot by right-clicking on Solution and selecting Insert > Thermal > Temperature. Right-click on the newly inserted Temperature item and select Evaluate All Results.

19. To export the thermal result to Maxwell, right-click on the Imported Load (Maxwell2DSolution), or Imported Load(Maxwell3DSolution) and select Export Results.

maxwell和workbench的联合仿真

20. To fully utilize the automation capabilities provided in ANSYS Workbench, select Imported Load (Maxwell2DSolution), or Imported Load(Maxwell3DSolution); and in its Detail window, select Yes for Export after Solve. With this option selected, users can continue the iteration between Maxwell/Thermal simulations from the Workbench schematic.

To “push” the exported thermal results back to Maxwell, right-click on Maxwell's Solution cell on the Workbench schematic and select Enable Update. Then, right-click again on Maxwell's Solution cell and select Update. This will trigger Maxwell to re-simulate its solution with thermal results.

To continue the solve iterations, repeat the following steps as needed:

a. Right-click on Thermal's Setup cell and select Refresh.

b. Right-click on Thermal's Setup cell and select Update.

c. Right-click on Maxwell's Solution cell and select Enable Update.

d. Right-click on Maxwell's Solution cell and select Updat

e.

Coupling Maxwell Designs with ANSYS Structural via

Workbench

Stress feedback coupling between Maxwell2D/3D V15 and ANSYS Structural R14 is supported via the Workbench schematic. Stress feedback is supported for Maxwell magnetostatic, eddy current, and transient types. Users also need to setup the design and geometry appropriately. An appropriate design has one or more solve setups that are enabled for stress feedback. The process for stress feedback coupling between Maxwell and ANSYS Structural is similar to that described in “Coupling Maxwell Designs with ANSYS Thermal via Workbench”.

1. The easiest way to add a Maxwell 2D or 3D design to a Workbench schematic is

to import a working design via Workbench File>Import. The imported design is placed in the Workbench schematic after it is successfully imported.

2. Next, insert a Static Structural system and change its Analysis Type to 2D or 3D, (depending on the Maxwell design type) by right clicking on the Geometry cell and selecting Properties. It is important to change the Steady-State Thermal system's analysis type before setting up its geometry.

maxwell和workbench的联合仿真

3. To setup the Static Structural system's geometry, you must first export the Maxwell geometry using sat or step format as follows:

a. Select the Modeler>Export menu item.

b. Select the desired model geometry format (sat or step), and the save location in the dialog box and save the file for use by ANSYS Workbench.

4. Import the file via the Geometry module of the Static Structural system.

a. To access the Geometry module, double click on the Geometry cell in the Static Structural system to launch DesignModeler.

b. Select File>Import External Geometry File and browse for the geometry file exported from Maxwell.

c. After the geometry file is imported, right-click on the root folder of the modeler project tree and select Generate. (When the geometry file is of a Maxwell 2D RZ design, users can rotate the geometry in DesignModeler by creating a body operation.)

maxwell和workbench的联合仿真

5. Close DesignModeler and refresh the Model cell of the Static Structural

system by right-clicking the Model cell and selecting Refresh.

6. The geometry mode of the Static Structural system can be changed via the ANSYS Mechanical user interface.

a. Launch Mechanical by double clicking the Setup cell of the Static Structural system.

b. Select Geometry in the project tree and the Definition of Geometry will be shown in the Detail window.

c. Select either Flexible or Rigid as the value for the property 2D (or 3D) Stiffness Behavior.

7. To setup the coupling, drag the Solution cell of the Maxwell system and drop

it on the Setup cell of the Static Structural system.

maxwell和workbench的联合仿真

8. Note that the Maxwell Solution cell is tagged with a “Lighting Bolt” symbol. Right-click on the Maxwell Solution cell and select Update. This will initiate a Maxwell simulation if it is not already solved. Once Maxwell's solution is available, the “Lighting Bolt” changes to a “Green Check”symbol.

9. To “push” the coupling into Static Structural, right-click on the Static Structural Setup cell and select Refresh.

10. After refresh is finished, you can launch ANSYS Mechanical by double-clicking the Setup cell to finish the coupling setup, which is similar to that described

in “Coupling Maxwell Designs with ANSYS Thermal via Workbench”.

Coupling Maxwell with Both ANSYS Thermal and Structural via Workbench

A Maxwell system can also be coupled with both thermal and stress systems via Workbench. The thermal system then serves as an “up-stream” system for the stress system. This means that the stress analysis takes both electromagnetic and thermal forces into consideration. In this scenario the user must select the same object(s) in the thermal and stress systems to apply the respective imported loads.

To setup the coupling, drag the “Solution” cell of the Maxwell system and drop it at the “Setup” cell of a Thermal and Static Structural (Stress) system. The user also needs to couple the Thermal and Static Structural systems to capture the effect of thermal force.

maxwell和workbench的联合仿真

The coupling framework is built on top of the existing Thermal Feedback. The Stress system will have additional Export Definition and Mapping Settings like Thermal.

maxwell和workbench的联合仿真

Example 1: “One” iteration

The image below illustrates a coupling setup where both the Thermal and Stress system are ready to be Updated. The Maxwell adaptive solution has converged in 3 passes. The Maxwell system has both thermal and stress feedback enabled.

maxwell和workbench的联合仿真

1. Right click on the Solution cell of Stress (Static Structural) and select Update.

a. The Setup of The rmal will be Updated with “em” loss from Maxwell.

b. The Solution of Thermal will be Updated and temperature will be exported to Maxwell.

c. The Setup of Stress will be Updated with thermal force from Thermal and force density from Maxwell.

d. Displacement will be exported to Maxwell after Stress finishes simulation.

2. Right click on the Solution cell of Maxwell and select Enable Update.

3. Right click on the Solution cell of Maxwell and select Update.

a. Maxwell re-simulates the 3rd pass with its mesh and the

temperature/displacement feedback.

b. The profile will show information about the feedback

maxwell和workbench的联合仿真

c. Both Revert to Initial Temperature and Revert to Zero Displacement menus are present in the analysis setup context menu.

maxwell和workbench的联合仿真

Example 2: Manual iteration

The image below illustrates the Workbench schematic after Example 1, where the 1st iteration has completed.

maxwell和workbench的联合仿真

1. Right click on the Solution cell of Stress and select Update.

a. The Setup of Thermal will be Refreshed and Updated with “em” loss from Maxwell.

b. The Solution of Thermal will be Updated and temperature will be exported to Maxwell.

c. The Setup of Stress will be Refreshed and Updated with thermal force from Thermal and force density from Maxwell.

d. Displacement will be exported to Maxwell after Stress finishes simulation.

2. Right-click on the Solution cell of Maxwell and select Enable Update.

3. Right-click on the Solution cell of Maxwell and select Update.

a. Maxwell re-simulates the 3rd pass with its mesh and new

temperature/displacement feedback.

b. The profile will show information about the feedback.

maxwell和workbench的联合仿真

Note that the delta temperature and displacement is being reported in the profile.

Example 3: Revert Maxwell Solution

The temperature and displacement in the Maxwell solution can be reverted separately.

1. Users select Revert to Initial Temperature in Maxwell.

A warning message displays notifying users about the invalidation of solution.

maxwell和workbench的联合仿真

2. Right-click on Maxwell analysis setup and select Analyze.

Maxwell re-simulates the 3rd pass with its mesh and displacement that was previously exported from Mechanical, but without temperature.

maxwell和workbench的联合仿真

3. Users select Revert to Zero Displacement in Maxwell, followed by right-clicking on Maxwell analysis setup and selecting Analyze.

Maxwell re-simulates the 3rd pass with its mesh without either temperature nor displacement.

maxwell和workbench的联合仿真

Example 4: Only Stress Feedback

The coupling setup is the same as in Example 1, with either one of the following differences:

?The Maxwell system is not enabled for thermal feedback (via SetObjectDisplacement). Note that since Maxwell is not enabled to support feedback, the “Export Result” proper ties should be available in the thermal system.

?The Maxwell system is enabled for thermal feedback, but users choose not to “Export Result’ in the thermal system. This is to disable the automatic “Export Results”.

maxwell和workbench的联合仿真

1. Right click on the Solution cell of Stress and select Update.

a. The Setup of Thermal will be Updated with “em” loss from Maxwell.

b. The Solution of Thermal will be Updated.

c. The Setup of Stress will be Updated with thermal force from Thermal and force density from Maxwell.

d. Displacement will be exported to Maxwell after Stress finishes simulation.

2. Right-click on the Solution cell of Maxwell and select Enable Update.

3. Right-click on the Solution cell of Maxwell and select Update.

a. Maxwell re-simulates the 3rd pass with its mesh and the displacement feedback.

b. The profile shows information about the feedback and Revert to Zero Displacement will be available in the solve setup context menu.

maxwell和workbench的联合仿真

maxwell和workbench的联合仿真

相关推荐
相关主题
热门推荐